Technical Issues

cPanel & WHM failed to update

By 13th November 2015 No Comments

I’m a firm believer in posting resolutions to issues I come across in my daily life, especially those that I couldn’t find an answer to online. So starting today I’m going to start posting these kind of things on my blog, hopefully they will help others who come across the same issues!

 

So after updating cPanel & WHM I was getting the following error on CentOS release 6.7

The system failed to update to the latest version of cPanel & WHM version 11.52 because it could not install basic requirements for cPanel & WHM. The specific failure was:

Sysup: Needed system RPMs were not installed: db4-devel

 

At first it just looked like I was missing the db4-devel RPM but my log had the following error:

Package db4-devel-4.7.25-20.el6_7.x86_64 is obsoleted by db53-devel-5.3.21-1ice.el6.x86_64 which is already installed

 

Turns out the a custom repository I had installed zeroc-ice-el6.repo was requiring db4-devel-4.7.25-20.el6_7.x86_64.rpm during the update, so by disabling this repository and then running the update script again everything ran smoothly.

Brendan

Author Brendan

More posts by Brendan

Leave a Reply